Service ThingPark Exchange seems to be down

Major incident ThingPark Exchange
2021-07-07 14:42 UTC · 39 minutes

Updates

Resolved

Roaming hub has been successfully migrated to the new infrastructure.

November 4, 2021 · 15:25 UTC
Monitoring

The incident is related to planned maintenance.

November 4, 2021 · 15:25 UTC

← Back