ECO platform down

Major incident Thingpark Community, PoCs and Dev1 Network Server for PoCs Network Server for Dev1 API and GUI Thingpark X Location Engine ThingPark X IoT-Flow
2021-03-10 06:47 UTC Β· 1 month, 1 week, 5 days, 8 hours, 28 minutes

Updates

Resolved

The platform is now fully operational since the beginning of April.

More information is available on http://community.thingpark.org/ for community users.

November 4, 2021 Β· 15:25 UTC
Update

2021-03-27T22:00:00Z

  • πŸ›  community.thingpark.org:
    • βœ” subscriber creation is working again, but still not available for customers as Interop Engine is not working yet,
    • βœ” Single Sign-On (SSO) to interop engine is also working
    • πŸ›  Interop engine validation needed.
  • βœ” TPXLE + ADA working for dev-ope instance
    • πŸ›  TPXLE not working for community instance without portal
  • βœ” All needed operator instances are now created.
  • πŸš₯ Next in line:
    • Subscribers, basestations and devices migration.
    • TPX decoders and drivers
    • Restore Partners sites
November 4, 2021 Β· 15:25 UTC
Update

2021-03-19, morning, Paris time. Disaster recovery plan is ongoing.

  • βœ” IoTFlow is installed

  • βœ” DX-API was updated to facilitate reprovisioning of subscribers and end-user accounts

  • πŸ›  ThingPark X Location Engine, Interoperability Engine are not back online, yet.

  • πŸš₯next in line:

    • validate TPXLE and ADA
    • achieve creation of all operator instances
    • migrate subscribers, basestations (gateways), devices
    • provision Community and Partner portals offers (including Interop)
November 4, 2021 Β· 15:25 UTC
Update

2021-03-18, morning, Paris time. Disaster recovery plan is ongoing.

  • βœ” The new community platform is up, including DX-API and IPSec.
  • πŸ›  IoTFlow, ThingPark X Location Engine, Interoperability Engine are not back online, yet.
  • πŸš₯ next in line for re-establishment:
    • TPX IoTFlow
    • ThingPark X Location Engine (TPXLE) + Abeeway Device Analyzer (ADA)
    • migration of operator instances, subscribers, basestations (gateways), devices
    • provisioning of Community offers (including Interop)
November 4, 2021 Β· 15:25 UTC
Update

We are moving the POC/dev1 platform to a new hoster.
It requires time and we will provide an Estimated Time of Arrival later this week.

November 4, 2021 Β· 15:25 UTC
Investigating
  • 2021-03-11T13:50 Z
    • after the fire πŸ”₯ that damaged multiple datacentres in Strasbourg, France, yesterday, the entire ECO environment is still down.
    • OVH is in disaster-recovery mode. In the next few days, they will let us know what services / data are gone and what we can restore. We will then assess the situation.
    • Our teams are working on restoring our own manual backups to a different location.
November 4, 2021 Β· 15:25 UTC
Issue
  • The infrastructure of ECO platform is down because of a fire in the datacenter.
  • 2021-03-10T09:35:00Z: the hosting company (OVH) just communicated they won’t be able to restore their datacenter today.
  • Information from hosting company OVH
November 4, 2021 Β· 15:25 UTC

← Back