US PROD - ThingPark 8.0 rollout from 2025-07-02 08:00 UTC to 2025-07-02 15:42 UTC

Scheduled maintenance US PROD Network Server for ThingPark Wireless API and GUI Network Server for ThingPark Enterprise
2025-07-02 08:00 UTC ยท 7 hours, 42 minutes

Updates

Resolved

Upgrade is completed.

July 2, 2025 ยท 15:42 UTC
Update

Upgrade is started.

July 2, 2025 ยท 08:00 UTC
Scheduled

Actility Network Operations is going to install Thingpark Wireless and Enterprise 8.0 on US PROD platform.

Please find details in release notes:
๐Ÿ“8.0 Product Release Notes
๐Ÿ“8.0 ThingPark Enterprise Release Notes

And issues fixed since the initial 8.0 release and this release (8.0.6):
๐Ÿ“8.0 Maintenance Release Notes
๐Ÿ“8.0 ThingPark Enterprise SaaS ChangeLog

This is a major release with the following impacts

  • Packets may be lost or queued during network server switchover
  • User may have to re-enter login information in GUI or API
  • The provisioning (all API and UIs) will be closed during part of the maintenance window

The upgrade is scheduled over several days and will consist on the following operations and impacts:

  • Preparation in background, to upgrade databases and message brokers - the week before the upgrade, without impact -
  • Upgrade of standby Network Server, which will handle a small percentage of the traffic (canary upgrade) - on the first day (July 1), network switchover impact
  • Upgrade of the backend and the main Network Server - on the second day (July 2), UI and API will be closed this day
July 2, 2025 ยท 08:00 UTC

โ† Back