EU PROD - TP 8.0 Rollout from 2025-03-11 09:00 UTC to 2025-03-12 21:30 UTC

Scheduled maintenance EU PROD Network Server for ThingPark Wireless Network Server for ThingPark Enterprise API and GUI Join Server for ThingPark Activation
2025-03-11 09:00 UTC · 1 day, 12 hours, 30 minutes

Updates

Monitoring

The upgrade has been successfully completed.

Background tasks are still running to finalize the activation of some new features, with no impact on system performance.

March 12, 2025 · 21:09 UTC
Update

The backend has been upgraded, but we need to extend the maintenance of the network servers up to (est.) 21:00 UTC.

March 12, 2025 · 17:15 UTC
Update

The second part of the upgrade to TP 8.0 is started.

March 12, 2025 · 09:03 UTC
Monitoring

Upgrade is completed for today. The ThingPark Enterprise network server is handling 50% of the Enterprise traffic in 8.0 version.

The IoT-Flow UI issue was also fixed.

Upgrade will continue tomorrow March 12 starting 09:00 UTC.

March 11, 2025 · 18:42 UTC
Update

20% of the ThingPark Enterpris traffic is now flowing through backup network server, which is upgraded in 8.0 version.

Background upgrades unexpectedly broken the IoT-Flow UI access, we are checking the issue.

March 11, 2025 · 16:45 UTC
Update

Upgrade is started, standby Network Server will be upgraded and will handle 20% of the traffic.

March 11, 2025 · 09:00 UTC
Scheduled

Actility Network Operations is going to install Thingpark Wireless and Enterprise 8.0 on EU PROD platform.

Please find details in release notes:
📝8.0 Product Release Notes
📝8.0 ThingPark Enterprise Release Notes

And issues fixed since the initial 8.0 release and this release (8.0.4):
📝8.0 Maintenance Release Notes
📝8.0 ThingPark Enterprise SaaS ChangeLog

The currently running version is 7.3.6g.

This is a major release with the following impacts

  • Packets may be lost or queued during network server switchover
  • User may have to re-enter login information in GUI or API
  • The provisioning (all API and UIs) will be closed during part of the maintenance window

The upgrade is scheduled over several days and will consist on the following operations and impacts:

  • Preparation in background, to upgrade databases and message brokers - the week before the upgrade, without impact -
  • Upgrade of standby Network Server, which will handle a small percentage of the traffic (canary upgrade) - on the first day (11 March), network switchover impact
  • Upgrade of the backend and the main Network Server - on the second day (12 March), UI and API will be closed this day
  • Post-upgrade tasks (background migrations and new features activation) - starting at the end of the 2nd day, without impact
February 26, 2025 · 14:02 UTC

← Back